AWS SQS queues issue - causes latency on Compliance Assessment results.
Incident Report for Dome9 Security
Resolved
We have resent all the relevant missing notifications, this incident is now resolved.
Sorry for any inconvenience.
Posted Apr 18, 2020 - 21:16 UTC
Update
We started to resend the missing relevant notifications, we will update after we sent all of them.
Posted Apr 18, 2020 - 16:30 UTC
Update
As a result of this issue the following continuous compliance notifications were not sent during 09:08 - 11:53 (UTC):
- Email per finding.
- SNS per finding.
- AWS Security hub.
- HTTP Endpoint per finding.

We are currently working on re sending those relevant findings.

Sorry for any inconvenience.
Posted Apr 17, 2020 - 20:47 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2020 - 13:27 UTC
Update
Continuous compliance is back to full operation and so is Notification service.
We have some notifications not sent which we are working to retrieve and send.
Posted Apr 17, 2020 - 13:24 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 17, 2020 - 12:56 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 17, 2020 - 12:55 UTC
Update
As a result from AWS issue all our notifications services suffers from latency.
Posted Apr 17, 2020 - 12:20 UTC
Identified
We are working with AWS on this matter, and monitoring the system on our end.
Posted Apr 17, 2020 - 11:22 UTC
This incident affected: CloudGuard Native US Region (Compliance Engine, Notification Services).